Deprecated: Function set_magic_quotes_runtime() is deprecated in /var/www/vhosts/tartan37.com/httpdocs/t37forum/common.php on line 88 Tartan37.com • View topic - Defective Jabsco Impeller - Core separation

Tartan37.com

Tartan 37 Owner's Forum - Ride the wind, but look good doing it!
The time is 26 Jun 2019 04:06

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 8 Posts ] 
Author Message
 Post subject: Defective Jabsco Impeller - Core separation
PostPosted: 14 Sep 2014 14:39 
Offline
Skipper

Joined: 09 Jul 2008 12:51
Posts: 232
I just had a fairly new Jabsco impeller fail today. It separated from the metal core.
It happened at a most inopportune time, in the ICW, really no where to stop and drop the hook. Put the wife on the radio to look out for barges but none came by in the time it took me to problem solve the damn thing.

I believe I read in someone's thread that the same thing happened to them. If I hadn't read that thread I wouldn't have removed the impeller and thoroughly inspected it and saw that the core had separated; all the fins look new however.

The impeller was about 5 months old. This forum is invaluable.


 
 Profile Email  
 
 Post subject: Re: Defective Jabsco Impeller - Core separation
PostPosted: 15 Sep 2014 23:36 
Offline
Skipper

Joined: 14 Jul 2012 20:36
Posts: 342
I had it happen three times, twice I got new impellers. The last time I went thru the system and found major blockage at the elbow going into the heat exchanger. There were pieces of old impellers. It's the back pressure which was causing my problem. This was also after talking to Jabsco, asking about defects. I also used an broken one in a pinch. Clean with actone and glued with 5-min epoxy the impeller to the hub. Worked for over an year.

Jabsco did say about 10 years ago there were some issues in manufactoring.

After removing the heat exchanger (later it was replaced) and cleaning, no more issues. Also there are the Globe impellers, which are blue silicone. The watermen love these, they can run dry forever.

Good luck, if you are in the Norfolk area and need parts/help let me know. 757-870-9685.

_________________
Hull #208, Puff Card
Southern Chesapeake Bay


 
 Profile Email  
 
 Post subject: Re: Defective Jabsco Impeller - Core separation
PostPosted: 16 Sep 2014 12:23 
Offline
Skipper

Joined: 09 Jul 2008 12:51
Posts: 232
In another thread I discovered a overheating problem; 186 degrees instead of 180 degrees.... the problem was the exhaust elbow. This is my first year in saltwater and it just about drove me crazy before I found it. I cleaned the elbow out and the engine ran 179/180 immediately however I believe the back pressure is what ruined my impeller.

By the way,,,,, I want to try out the "run dry" Globe impellers in the future. Do you have a website and cross referenced item/part number for the jabsco 5616-0001 ?

I'm in Gulf Shores, Alabama


 
 Profile Email  
 
 Post subject: Re: Defective Jabsco Impeller - Core separation
PostPosted: 16 Sep 2014 17:10 
Offline
Skipper

Joined: 14 Jul 2012 20:36
Posts: 342
Jabsco Impeller 5616-0001 cross refeences to Globe Impeller 032SS. It looks like Globe stop making them.

After a long search, did I find one guy who still has them. I called and he verified they have them. Don't forget the gasket Jabsco part 2995-000, less than $3 (not supplied with impeller).

http://www.marineoutfitters.ca/index.cf ... e%2021-302


Here's a website that talks about their benefits.

http://www.marinepartssource.com/newdet ... 20Impeller

Here's a break down of our pump.

http://www.pumpagents.com/partpages/Jab ... -0011.html

 

_________________
Hull #208, Puff Card
Southern Chesapeake Bay


 
 Profile Email  
 
 Post subject: Re: Defective Jabsco Impeller - Core separation
PostPosted: 16 Sep 2014 18:29 
Offline
Skipper

Joined: 09 Jul 2008 12:51
Posts: 232
Many thanks for the links. The pump is only a year old and I have plenty of seals.


 
 Profile Email  
 
 Post subject: Re: Defective Jabsco Impeller - Core separation
PostPosted: 10 Jun 2018 01:47 
Offline
Navigator

Joined: 25 Apr 2016 10:25
Posts: 90
How did the Globe Impeller 032SS work for you?


 
 Profile Email  
 
 Post subject: Re: Defective Jabsco Impeller - Core separation
PostPosted: 28 Jan 2019 12:02 
Offline
Navigator

Joined: 25 Apr 2016 10:25
Posts: 90
Does anyone have any experience with the Globe Impeller? It looks like the website still has them in stock. I was going to give them a call to make sure.
[url]
https://www.marineoutfitters.ca/index.c ... ocation=US[/url]


 
 Profile Email  
 
 Post subject: Re: Defective Jabsco Impeller - Core separation
PostPosted: 23 Feb 2019 18:57 
Offline
Skipper

Joined: 21 Oct 2006 18:12
Posts: 257
I used the Globe on my W40 and it worked fine in the water for the season, the problem I had was in trying to winterize it out of the water by putting antifreeze into the water filter - it would not suck the fluid. I switched to regular impeller and it worked fine. So either I have a bit more back pressure in the system or the Globes are a bit more flexible? I think the latter. I keep them as spares however.

Richard


 
 Profile Email  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 Posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB © 2002, 2006 phpBB Group